怎么为hostgator老帐户开启PHP5.3

  • A+
所属分类:Hostgator问题解答
hawkhost

在《hostgator主机是否支持php5.3》中我们提到过对于2013年5月1日后购买的和2013年5月16日之后购买的reseller hosting,目前默认的处理程序已经是PHP5.3了!所以,如果你现在购买hostgaotr主机,就不需要再为你的主机帐户是否支持PHP5.3操心了!但如果是在这之前购买的主机账户,想要使用PHP5.3,就得为你的hostgator帐户开启PHP5.3了!那么,怎么为hostgator老帐户开启PHP5.3呢?

hostgator支持的php模块

下面我们就将针对hostgator不同类型的主机开启PHP5.3的方法做一个详细的说明:

Shared and Reseller主机帐户开启PHP5.3

目前所有新的shared and reseller 主机帐户都已经安装了PHP5.3.10 (或更高版本) 。对于老帐户来说,想要支持PHP5.3也很简单,只需要在 .htaccess文件中添加下面的代码就可以了!

# Use PHP 5.3
AddType application/x-httpd-php53 .php

Windows Shared主机帐户开启PHP5.3

Windows Shared 主机的用户可以自己开启PHP5.3,你只需要按以下步骤进行操作就可以了:

  1. 在帐户管理后台点击Websites & Domains 标签
  2. 选择需要使用 PHP5.3的域名
  3. 定位到 Web Scripting & Statistics部分
  4. 检查 PHP support 框.
  5. 在下拉框中选择PHP 5.3版本
  6. 点击 OK 按键

Linux Dedicated Servers和Windows Dedicated Servers开启PHP5.3的方法

如果你购买了hostgator独立服务器——不管是Linux还是Windows独立服务器,想要开启PHP5.3的话都得联系 support@hostgator.com,你自己最好不要进行什么操作

VPS with cPanel

和上面一样,你必须邮件联系 support@hostgator.com让他们帮你安装PHP5.3才行

VPS with Plesk

新的VPS已经安装了 PHP 5.3, 老的VPS账户想要升级PHP到 5.3 需邮件联系 support@hostgator.com 。

VPS with VZ only

VPS 没有安装 cPanel or Plesk 那就意味着这个主机默认情况没有被安装 PHP 程序,你可以自己安装任意版本的PHP,如果你不懂,还是算了!VPS说实话,个人感觉不是拿来用的,VPS就是拿来折腾的,呵呵!

Linux Chilisoft ASP

PHP 5.3 没安装在这种主机上,也不会被安装,呵呵。

如果你对自己主机情况不了解,或不知该怎么办,那也没有关系,直接问hostgator客服吧,他们的客服可是非常棒的!

hawkhost
vps

发表评论

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: